Bouton avec image

Aide sur les Interfaces Graphique Utilisateurs (GUI).
Règles du forum
.
Répondre
dopi
Niveau 1
Niveau 1
Messages : 7
Enregistré le : lun. 23 sept. 2019 14:01
Status : Hors ligne

Bouton avec image

#1

Message par dopi » mar. 22 oct. 2019 16:42

Bonjour,

Je reviens vers la communauté pour un problème surement simple pour vous mais sur lequel je m'arrache les cheveux :P
Je suis en train de tester la mise en place d'images pour mes boutons. Voici le code:
#include <ButtonConstants.au3>
#include <GUIConstantsEx.au3>
#include <WindowsConstants.au3>
#Region ### START Koda GUI section ### Form=
Global $Form2 = GUICreate("Interface 1", 576, 432, 208, 255)
Global $Button1 = GUICtrlCreateButton("Button1", 184, 168, 171, 65, $BS_BITMAP)
GUICtrlSetImage(-1, "C:\app\img\system\test.bmp", -1)
GUISetState(@SW_SHOW)
#EndRegion ### END Koda GUI section ###

While 1
 $nMsg = GUIGetMsg()
 Switch $nMsg
  Case $GUI_EVENT_CLOSE
   Exit

 EndSwitch
WEnd
Le fichier est bien au bon endroit soit: C:\app\img\system\test.bmp et c'est bien un BMP (créé sous GIMP) toutefois, lorsque j’exécute le code, j'ai un bouton de base "Boutton1" qui apparait et non mon image. La GUI est générée par Koda.
J'ai vu que ce problème est parfois relevé sur le forum, mais aucune solution ne semble me correspondre... :?

En PJ l'image en question.
Auriez-vous une idée du problème ???

Merci d'avance pour votre aide.
Bonne journée.
Fichiers joints
Images.zip
(46.2 Kio) Téléchargé 16 fois
Images.zip
(46.2 Kio) Téléchargé 16 fois

Avatar du membre
DimVar
Niveau 10
Niveau 10
Messages : 835
Enregistré le : ven. 30 mai 2008 14:08
Status : Hors ligne

Re: Bouton avec image  

#2

Message par DimVar » mer. 23 oct. 2019 11:11

Bonjour Dopi,

Erreur sur le format de ton image.
Je l'ai passé avec MSPaint, sauvegardé au format BMP 24bit, et plus de soucis.

Pense dans ce cas à variabiliser le return code de ta commande GUICtrlSetImage pour savoir si elle se deroule bien.
Dans l'exemple, j'ai mis l'image dans le dossier du script.
#include <ButtonConstants.au3>
#include <GUIConstantsEx.au3>
#include <WindowsConstants.au3>
#Region ### START Koda GUI section ### Form=
Global $Form2 = GUICreate("Interface 1", 576, 432, 208, 255)
Global $Button1 = GUICtrlCreateButton("Button1", 184, 168, 171, 65, $BS_BITMAP)
$toto = GUICtrlSetImage($Button1, @ScriptDir & "\test.bmp")
ConsoleWrite($toto & @CRLF)
GUISetState(@SW_SHOW)
#EndRegion ### END Koda GUI section ###

While 1
 $nMsg = GUIGetMsg()
 Switch $nMsg
  Case $GUI_EVENT_CLOSE
   Exit

 EndSwitch
WEnd
Cdlt, Dimvar.
Fichiers joints
test.zip
(445 Octets) Téléchargé 15 fois
test.zip
(445 Octets) Téléchargé 15 fois
Screenshot_5.png
Screenshot_5.png (4.39 Kio) Vu 921 fois
Screenshot_5.png
Screenshot_5.png (4.39 Kio) Vu 921 fois
N'évoquons pas la pierre, les jeunes risqueraient d'en poire !

dopi
Niveau 1
Niveau 1
Messages : 7
Enregistré le : lun. 23 sept. 2019 14:01
Status : Hors ligne

Re: Bouton avec image

#3

Message par dopi » mer. 23 oct. 2019 14:58

Bonjour DimVar,

Merci beaucoup pour le coup de main et les conseils. C'est bien noté :)
Je suis passé par Gimp pour la création de l'image, j'ai du zapper un paramètre lors de l'enregistrement en BMP. Je vais creuser !

Bonne journée !

Répondre