[R] _Winapi

Aide et conseils concernant AutoIt et ses outils.
Règles du forum
.
Répondre
Avatar du membre
DimVar
Niveau 10
Niveau 10
Messages : 834
Enregistré le : ven. 30 mai 2008 14:08
Status : Hors ligne

[R] _Winapi  

#1

Message par DimVar » ven. 05 juil. 2019 11:40

Bonjour,

Suite à la découverte de _Winapi..., je suis tombé la-dessus :
https://www.autoitscript.fr/autoit3/doc ... nState.htm

M'interressant au sujet SetCursorPos (car sur ma VM, le mouse Move ne fonctionne pas, et qu'il semble que je doive passer par l'API windows pour une raison que j'ignore) j'ai donc testé l'URL :
https://www.autoitscript.fr/autoit3/doc ... sorPos.htm
Mais marche po...

Qu'est ce que cela veut dire ?
- Que la doc n'est pas encore sur le site ?
- Que toute les fonctions de l'API ne sont pas documenté ?
- Ou tout simplement que je m'y prends mal ou que j'ai rien compris ?


Merci.

Ps : la notion d'API Windows est toute fraiche pour moi.
Modifié en dernier par DimVar le mar. 09 juil. 2019 09:04, modifié 1 fois.
N'évoquons pas la pierre, les jeunes risqueraient d'en poire !

Avatar du membre
walkson
Modérateur
Modérateur
Messages : 721
Enregistré le : ven. 12 août 2011 18:49
Localisation : Essonne
Status : Hors ligne

Re: [..] _Winapi

#2

Message par walkson » ven. 05 juil. 2019 12:51

Bonjour,
Je n'ai pas trouvé _WinAPI_SetCursorPos() dans l'aide ou ailleurs mais vous pouvez créer cette fonction avec ce code
$x = @DesktopWidth/2
$y = @DesktopHeight/2

DllCall("user32.dll", "int", "SetCursorPos", "int", $x, "int", $y)
Cordialement,
Walkson
"Horas non numero nisi serenas " Le canon de midi

Avatar du membre
DimVar
Niveau 10
Niveau 10
Messages : 834
Enregistré le : ven. 30 mai 2008 14:08
Status : Hors ligne

Re: [..] _Winapi

#3

Message par DimVar » mar. 09 juil. 2019 09:03

Merci pour l'aide.
Je vais aller voir du coté du forum anglais, car ca ne fonctionne tjs pas sur une VM VMWARE... :?
N'évoquons pas la pierre, les jeunes risqueraient d'en poire !

Répondre