Imageshearch variation ?

Aide et conseils concernant AutoIt et ses outils.
Règles du forum
.
Répondre
Misa10
Niveau 3
Niveau 3
Messages : 38
Enregistré le : sam. 14 avr. 2018 11:50
Status : Hors ligne

Imageshearch variation ?

#1

Message par Misa10 » sam. 29 déc. 2018 01:32

Bonjour , j'utilise l'UDF imageshearch . Et dans mon script plusieurs mon script va chercher une image avec la fonction imageshearch jusqu'à la trouver puis va faire une certaine action . Donc quand je le fait en interne sur mon pc tout marche parfaitement . Quand j'ai voulu le partager a des potes eux le script ne trouve aucune image . Donc j'ai changé la variation de 0 a 255 donc ça a réglé le bug a certaines personnes mais certaines on toujours le bug donc par exemple sur un pote j'ai pris les screenshots sur son pc via TeamViewer et la ça marche pour mon potes . Mais avec les screenshots marche pas je comprends pas pourquoi . Si quelqu'un peux m'expliquer. Pourtant c'est bien les même images et tout ça doit être une histoire de couleur de pixels ou autre pourtant j'ai mis la variation a 255 . Si quelqu'un peux m'expliquer pour que je trouve une solution a ce problème .

Avatar du membre
DimVar
Niveau 10
Niveau 10
Messages : 763
Enregistré le : ven. 30 mai 2008 14:08
Status : Hors ligne

Re: Imageshearch variation ?

#2

Message par DimVar » sam. 29 déc. 2018 10:56

Bonjour,

Curieux ce post, quand on voit vos précédents post.
On dirait que vous avez copié/collé une demande d'autrui sans aucun formatage orthographique.
Vu le peu d'infos... (code, but du scrpit, fonctions,...) je ne peux vous aider. Je laisse donc à d'autres, l'aide à vous apporter.


Cdlt,
Dimvar.
N'évoquons pas la pierre, les jeunes risqueraient d'en poire !

Misa10
Niveau 3
Niveau 3
Messages : 38
Enregistré le : sam. 14 avr. 2018 11:50
Status : Hors ligne

Re: Imageshearch variation ?

#3

Message par Misa10 » sam. 29 déc. 2018 11:50

DimVar a écrit :
sam. 29 déc. 2018 10:56
Bonjour,

Curieux ce post, quand on voit vos précédents post.
On dirait que vous avez copié/collé une demande d'autrui sans aucun formatage orthographique.
Vu le peu d'infos... (code, but du scrpit, fonctions,...) je ne peux vous aider. Je laisse donc à d'autres, l'aide à vous apporter.


Cdlt,
Dimvar.
Bonjour comme j'ai expliqué plus haut mon script n'a pas de problème . J'utilise l'UDF shearch image qui cherche a chercher une image tout simplement avec la fonction "imageshearch" qui cherche l'image sur tout l'écran . J'ai donc un dossier avec mes BMP et le script je l'ai partager à des amis mais sur certaines personnes les images ne sont pas trouvé même avec une variation a 255 . Je répète le bug ne viens pas de mon script car j'ai fait plusieurs test et il marche parfaitement chez moi et parfaitement chez d'autres amis . J'aimerais juste comprendre comment c'est possible qu'il ne trouve pas les images chez certaines personnes.

Répondre