Pack AutoIt-Fr - Installer AutoIt et ses outils en 1 clic.

Forum de promotion sur des outils créés pour AutoIt
Avatar du membre
Tlem
Site Admin
Site Admin
Messages : 11288
Enregistré le : ven. 20 juil. 2007 20:00
Localisation : Bordeaux
Status : Hors ligne

Re: Pack AutoIt-Fr - Installer AutoIt et ses outils en 1 cli

#61

Message par Tlem » dim. 29 déc. 2013 23:38

Merci jl56, j’essaierais de m'y atteler dés que j'aurais suffisamment de temps.

Concernant le changement de la coloration syntaxique, cela est dut à la nouvelle version de Scite4AutoIt. C'est quelque chose qui à été débattus sur le forum US et l'équipe de DEV à décidé de valider cette nouvelle coloration. Pour conserver l'ancienne version, il suffit de faire comme vous l'avez fait. ;)

Merci.

Avatar du membre
Tlem
Site Admin
Site Admin
Messages : 11288
Enregistré le : ven. 20 juil. 2007 20:00
Localisation : Bordeaux
Status : Hors ligne

Re: Pack AutoIt-Fr - Installer AutoIt et ses outils en 1 cli

#62

Message par Tlem » lun. 30 déc. 2013 01:00

Bonsoir à tous et une nouvelle fois, bonnes fêtes de fin d'année.
Pour éviter de faire mentir jchd qui avait annoncé ma distribution de cadeaux (voir ici), voici enfin la mise à jour 2.3.0 du Pack AutoIt-Fr (Voir première page pour le lien et les détails des nombreuses modifications).

Celle-ci est relativement importante sur deux points :
  • - La taille du pack passe de 18 Mo à 24 Mo suite à l'embonpoint des installateurs de AutoIt et Scite4AutoIt. Cet embonpoint est surtout lié à l'ajout de nombreuses fonctionnalités, corrections de bugs, l'intégration de WinAPIEx, ainsi que de quelques outils bien sympathiques. Soyons content de cette profusion de cadeaux offert par Jon et son équipe.

    - La deuxième grosse modification, concerne la correction de quelques bugs liés au pack lui même ainsi qu'aux outils que j'ai rajouté. Sont pris en compte les modifications sur les problèmes exposés quelques messages avant par jl56 et quelques autres. J'ai aussi pris le temps d'apporter pas mal de modifications interne et externe afin de rendre le pack plus agréable et moins "casse-pied" avec certaines boite de dialogue.
    Bien qu'il reste en version 2.x, le pack n'en demeure pas moins modulable et utile. Je ne sais pas quand j'aurais le temps de continuer à plancher sur la v3, mais j'espère bien que 2014 sera l'année de gros changements. ^^
Par manque de temps, je n'ai testé le pack que sous XP 32 bits, donc tout retour de mauvais fonctionnement sur d'autres versions de Windows sont bienvenu.

Voilà, je vous laisse ouvrir le cadeau et jouer avec. Comme l'a signalé jchd, une version 3.3.10.1 d'AutoIt, corrigeant quelques bugs mineures devrait voir le jour prochainement. Je mettrais probablement à jour le pack après avoir eu un certain nombre de retour afin de le corriger et ainsi de faire tout en même temps.

Salutations
Thierry
.

Avatar du membre
jl56
Niveau 7
Niveau 7
Messages : 357
Enregistré le : mer. 24 oct. 2007 21:42
Localisation : 56000
Status : Hors ligne

Re: Pack AutoIt-Fr - Installer AutoIt et ses outils en 1 cli

#63

Message par jl56 » lun. 30 déc. 2013 21:48

@Tlem

ça fonctionne sur mon win 8.1

Merci pour ce travail

A+ JL56

Avatar du membre
Tlem
Site Admin
Site Admin
Messages : 11288
Enregistré le : ven. 20 juil. 2007 20:00
Localisation : Bordeaux
Status : Hors ligne

Re: Pack AutoIt-Fr - Installer AutoIt et ses outils en 1 cli

#64

Message par Tlem » sam. 04 janv. 2014 00:33

Il semble que je n'avais pas lié correctement le fichier et le lien. Certains (23) sont allez directement dans le dossier Download et ont eu la dernière version, les 104 autres ont probablement eu la version avec la 3.3.10.0 d'AutoIt. :oops:

J'ai corrigé le nom du fichier, donc vous pouvez mettre à jour. Il n'y à pas grande différence. Juste AutoIt 3.3.10.1 et la dernière de Scite4AutoIt.

.

Avatar du membre
RL77LUC
Niveau 5
Niveau 5
Messages : 173
Enregistré le : mar. 21 sept. 2010 15:54
Status : Hors ligne

Re: Pack AutoIt-Fr - Installer AutoIt et ses outils en 1 cli

#65

Message par RL77LUC » sam. 04 janv. 2014 15:23

Je mets à disposition un pack 2.3.1 légèrement modifié (et plus lourd). Les différences par rapport à la 2.3.0 sont que AutoIt 3.3.10.2 et AutoIt Beta 3.3.11.0 sont inclus.

Vu que les exe ne sont pas autorisés sur le forum (Jamais compris pourquoi d'ailleurs, suffit de le mettre dans un ZIP...), j'ai mis ça sur MEGA : https://mega.co.nz/#!uYIH3IzR!bTnt32-6k ... 3ZrUH8eCaQ

Si vraiment vous préférez une PJ, je l'uploaderai en ZIP sur le forum.

Avatar du membre
ricky
Niveau 7
Niveau 7
Messages : 443
Enregistré le : ven. 06 févr. 2009 09:25
Localisation : Suisse
Status : Hors ligne

Re: Pack AutoIt-Fr - Installer AutoIt et ses outils en 1 cli

#66

Message par ricky » sam. 04 janv. 2014 21:28

Hello,

je suis sous windows 7 pro sp1 x64 et lorsque je clique sur AutoItSecure, j'ai un message box blanc :
Install_v2.3.0.PNG
Pour information, j'ai déjé SandBoxie installé sur mon pc.

Avatar du membre
Tlem
Site Admin
Site Admin
Messages : 11288
Enregistré le : ven. 20 juil. 2007 20:00
Localisation : Bordeaux
Status : Hors ligne

Re: Pack AutoIt-Fr - Installer AutoIt et ses outils en 1 cli

#67

Message par Tlem » sam. 04 janv. 2014 23:04

Mise à jour 2.3.1 du Pack AutoIt-Fr (Voir première page pour le lien et le détail des modifications).

@ricky
Désolé, c'était une boite de dialogue pour débogué que j'avais oublié. C'est corrigé dans la nouvelle version.

@RL77LUC
Merci pour votre participation. Concernant l'intégration de la bêta, je préfère laisser le soin aux utilisateurs de télécharger et d'installer la bêta qu'il souhaite, car celle-ci change tellement souvant, qu'il faudrait mettre à jour le pack à chaque fois et cela n'est pas envisageable. De plus la bêta rajoute quand même quelques Mo qui ne sont pas forcément souhaitables par tous le monde. Sans compter les contraintes liées à son utilisation sous Windows 8 !

Concernant les Exes, j'ai fait ce choix car l'AV de la machine qui réalise les sauvegardes hebdomadaire de la totalité des fichiers du forum, réagit parfois assez mal à certains scripts compilés. De plus, un script compilé peut contenir n'importe quoi et l'utilisateur ne peux pas contrôler le contenu sans se mettre 'hors la loi', donc pour au moins ces deux raisons, je préfère les éviter. C'est d'ailleurs pour cela que le pack est passé d'un script compilé a une archive 7Zip auto-extractible. ^^

.

Avatar du membre
ricky
Niveau 7
Niveau 7
Messages : 443
Enregistré le : ven. 06 févr. 2009 09:25
Localisation : Suisse
Status : Hors ligne

Re: Pack AutoIt-Fr - Installer AutoIt et ses outils en 1 cli

#68

Message par ricky » dim. 05 janv. 2014 21:32

Je dois être blond, mais cette nouvelle version, impossible de la dezipper. Je fais qqch de faux? Et si je presse sur cancel, celui-ci ne se ferme pas, je suis obligé de la tuer... Toujours sur le même pc...

Avatar du membre
Tlem
Site Admin
Site Admin
Messages : 11288
Enregistré le : ven. 20 juil. 2007 20:00
Localisation : Bordeaux
Status : Hors ligne

Re: Pack AutoIt-Fr - Installer AutoIt et ses outils en 1 cli

#69

Message par Tlem » dim. 05 janv. 2014 21:52

Bonsoir ricky.
Je viens de tester l'installation du Pack AutoIt-Fr 2.3.1 dans une VM avec Windows 7 x64 et en dehors d'un petit problème concernant le menu contextuel sur script au3 (que je corrigerais dans la prochaine version), le pack s'est installé parfaitement.

.

Avatar du membre
ricky
Niveau 7
Niveau 7
Messages : 443
Enregistré le : ven. 06 févr. 2009 09:25
Localisation : Suisse
Status : Hors ligne

Re: Pack AutoIt-Fr - Installer AutoIt et ses outils en 1 cli

#70

Message par ricky » dim. 05 janv. 2014 21:59

Bonsoir,

je l'ai téléchargé à nouveau (pour la xème fois), et ça marche. J'ai pas tout compris...
Merci pour ton pack et tes réponses et bonne année.

Avatar du membre
Tlem
Site Admin
Site Admin
Messages : 11288
Enregistré le : ven. 20 juil. 2007 20:00
Localisation : Bordeaux
Status : Hors ligne

Re: Pack AutoIt-Fr - Installer AutoIt et ses outils en 1 cli

#71

Message par Tlem » lun. 06 janv. 2014 09:02

Mise à jour 2.3.2 du Pack AutoIt-Fr (Voir première page pour le lien et le détail des modifications).

Dans les grosses nouveautés, c'est le support complet de l'installation sur OS 64 bits (Traduction des Menus), l'ajout de deux outils que je trouve indispensables :
  • - Control Viewer (créé par Yashied) qui est l'équivalent de AutoIt3 Window Info, mais plus complet et prenant en charge certains contrôles non supportés par AWI.

    - Resources Viewer And Compiler (créé par trancexx) et qui permet tout comme ResHacker d'éditer/voir les ressources d'un programme ou d'une DLL, mais qui permet aussi et surtout de créer une DLL de ressources, afin de stocker images, sons et d'autres choses.
.

Avatar du membre
ricky
Niveau 7
Niveau 7
Messages : 443
Enregistré le : ven. 06 févr. 2009 09:25
Localisation : Suisse
Status : Hors ligne

Re: Pack AutoIt-Fr - Installer AutoIt et ses outils en 1 cli

#72

Message par ricky » lun. 06 janv. 2014 09:23

Hello,
merci pour cette nouvelle maj, tu ne mets pas à jour scitejump?

Avatar du membre
Tlem
Site Admin
Site Admin
Messages : 11288
Enregistré le : ven. 20 juil. 2007 20:00
Localisation : Bordeaux
Status : Hors ligne

Re: Pack AutoIt-Fr - Installer AutoIt et ses outils en 1 cli

#73

Message par Tlem » lun. 06 janv. 2014 09:32

Il me semble bien que SciteJump est intégré à Scite4AutoIt et donc avec la nouvelle version, il doit être à jour.

.

Avatar du membre
Tlem
Site Admin
Site Admin
Messages : 11288
Enregistré le : ven. 20 juil. 2007 20:00
Localisation : Bordeaux
Status : Hors ligne

Re: Pack AutoIt-Fr - Installer AutoIt et ses outils en 1 cli

#74

Message par Tlem » sam. 08 févr. 2014 12:57

Mise à jour 2.3.3 du Pack AutoIt-Fr (Voir première page pour le lien et le détail des modifications).

Bug trouvé par xeno (Guillemets en trop dans les entrées de la base de registre pour le menu contextuel d'ouverture de SciTE). merci à lui.

.

Avatar du membre
cetipabo
Niveau 6
Niveau 6
Messages : 264
Enregistré le : lun. 20 déc. 2010 17:24
Status : Hors ligne

Re: Pack AutoIt-Fr - Installer AutoIt et ses outils en 1 cli

#75

Message par cetipabo » dim. 23 févr. 2014 13:33

NicoMasterChief a écrit :J'ai trouvé d'où venait le problème, en fait dans les options du Koda de la version officielle, la "méthode d'exécution interface" est en associé, c'est-à-dire qu'elle ouvre un fichier "test" dans Scite avec le code de la GUI créée. Mais dans votre version, vous avez modifié cela et la méthode est en "manuel". Et vous avez eu raison, c'est plus pratique, la GUI est directement générée sans passer par Scite. Or, lorsque avez rentré le chemin de l'exécutable AutoIt, vous avez mis : "C:\Program Files\AutoIt3\AutoIt3.exe". Cependant, votre PC était sûrement un 32 bits, mais le mien est un 64 bits donc j'ai 2 dossiers : "Program Files" (pour les fichiers 64 bits) et "Program Files (x86)" (pour les fichiers 32 bits). AutoIt étant 32 bits, il faut que je mette "C:\Program Files (x86)\AutoIt3\AutoIt3.exe" pour que ça se lance.

Dans le fichier de configuration associé à Koda : "fd.xml", il faudrait insérer le chemin de l'exécutable selon l'architecture de l'OS.
Bonjour, je viens de télécharger à l'instant la dernière version du pack et je m'aperçois que le problème est revenu :wink:

D'autre part, depuis la version 3.3.10.2 une nouvelle version d'autoit3wrapper v2.1.4.5 (qui corrige un bug) est disponible:
http://www.autoitscript.com/site/autoit ... downloads/

Avatar du membre
Tlem
Site Admin
Site Admin
Messages : 11288
Enregistré le : ven. 20 juil. 2007 20:00
Localisation : Bordeaux
Status : Hors ligne

Re: Pack AutoIt-Fr - Installer AutoIt et ses outils en 1 cli

#76

Message par Tlem » sam. 07 juin 2014 15:32

Mise à jour 2.3.4 du Pack AutoIt-Fr (Voir première page pour le lien et le détail des modifications).

Prise en compte des remarques et conseils de NicoMasterChief et cetipabo.

.

Avatar du membre
Tlem
Site Admin
Site Admin
Messages : 11288
Enregistré le : ven. 20 juil. 2007 20:00
Localisation : Bordeaux
Status : Hors ligne

Re: Pack AutoIt-Fr - Installer AutoIt et ses outils en 1 cli

#77

Message par Tlem » sam. 07 juin 2014 15:38

Mise à jour 2.3.5 du Pack AutoIt-Fr (Voir première page pour le lien et le détail des modifications).

[blink]*** Attention[/blink], cette mise à jour prend en compte les nouvelles versions d'AutoIt et de SciTE4AutoIt qui utilisent maintenant le dossier %LOCALAPPDATA%\AutoIt v3 en tant que dossier de travail et de stockage des fichiers de configuration.

Pensez à bien vérifier que vos anciens fichiers de configuration sont bien sauvegardés avant la mise à jour.

.

Avatar du membre
cetipabo
Niveau 6
Niveau 6
Messages : 264
Enregistré le : lun. 20 déc. 2010 17:24
Status : Hors ligne

Re: Pack AutoIt-Fr - Installer AutoIt et ses outils en 1 cli

#78

Message par cetipabo » mar. 24 juin 2014 14:41

Merci pour ce nouveau Pack.

Pour les personnes utilisant une version 64bit de Windows :
éditez le fichier C:\Program Files (x86)\AutoIt3\SciTE\Koda\fd.xml

et remplacez :

Code : Tout sélectionner

<au3path>C:\Program Files\AutoIt3\AutoIt3.exe</au3path>
par

Code : Tout sélectionner

<au3path>C:\Program Files (x86)\AutoIt3\AutoIt3.exe</au3path>
Sinon pas de prévisualisation de la GUI avec KODA. :wink:

Avatar du membre
franco
Niveau 6
Niveau 6
Messages : 273
Enregistré le : lun. 03 oct. 2011 21:37
Localisation : Liévin
Contact :
Status : Hors ligne

Re: Pack AutoIt-Fr - Installer AutoIt et ses outils en 1 cli

#79

Message par franco » sam. 28 juin 2014 10:10

Bonjour. ;)

Je viens d'installer la dernière version d'autoit : nickel.
Je viens d'installer le pack AutoIt-Fr : problème ^^

Sous windows 8.1 (x64)


J'ai lancé une VM sous windows 7 (x64) et windows XP SP3 : même problème.

Voici une capture d'écran :
Image

for $i = $aSciTEUserFile[0] to 1 step -1
L'erreur (ou non je ne sais pas) provient de la variable soulignée...
Une variable dite... inaccessible.


Voilà :)


@+
L'entraide, c'est mon dada ;)

Avatar du membre
Tlem
Site Admin
Site Admin
Messages : 11288
Enregistré le : ven. 20 juil. 2007 20:00
Localisation : Bordeaux
Status : Hors ligne

Re: Pack AutoIt-Fr - Installer AutoIt et ses outils en 1 cli

#80

Message par Tlem » sam. 28 juin 2014 16:26

Merci franco. Je viens de faire la modification (la version du pack n'a pas changé). Si vous en avez la possibilité, essayez le et comme d'habitude, faites moi le retour. ;)

Répondre